Glad You're Ready. Let's Get Started!

Let us know how we can contact you.

Thank you!

We'll respond shortly.

Standup 08/07/2009: Rubygems 1.3.5 fail?

Interesting Things

  • One project had trouble installing the Rails 2.3.3 with the most recent version of Rubygems (1.3.5) on a Gentoo box (EY Solo instance). Installing the gem on an OSX box worked fine with the same versions. No obvious solution presented itself, other than to roll back to Rubygems version 1.3.1.

  • If you do update your Rubygems version to 1.3.5 and you use Geminstaller you must update your Geminstaller gem to 0.5.2; Rubygems made some changes that break Geminstaller’s implementation. If you use an older version of Rubygems then keep using Geminstaller 0.5.1.

  • One project wanted to find all places where they needed to escape user input on their site, so they injected <script>alert('foo');</script> into every text field in the database, ran through their site, and looked for every place that a pop up box appeared.

  1. Chad Woolley says:

    Actually, GemInstaller should be backward compatible with all versions of RubyGems back to the beginning of time (or at least 0.8.something) – and even ran CI tests against old versions until that got too hard. [Here’s more info if you are interested]( Please take advantage of my version-checking masochism and upgrade to the latest.

Post a Comment

Your Information (Name required. Email address will not be displayed with comment.)

* Copy This Password *

* Type Or Paste Password Here *