Glad You're Ready. Let's Get Started!

Let us know how we can contact you.

Thank you!

We'll respond shortly.

  • Blog Navigation
Setting up & Troubleshooting Bugzilla with Tracker

Bugzilla is a popular Tracker integration and fairly straightforward to set up. In general all you need is here:

But if you do receive an error message instead of bugs loading in your Bugzilla integration panel, here are some tips to get past them. The following also applies to other error messages, but these are the most common:

“Unable to load bugs – Please check your URL and remember to include http:// and exclude the xmlrpc.cgi.”
“Unable to load bugs – There was a problem processing your request.”

You can take the first error literally, but there are also some other causes for it which aren’t obvious.

  1. We only support versions 3.4.x and above. That said, at the time of writing, we recommend 4.0.9 as we’re looking into an issue with the the 4.2.0 release and possibly some preceding minor versions and release candidates.
  2. If you haven’t changed the integration’s “Bug ‘Status’ values to exclude” (currently RESOLVED, VERIFIED, CLOSED), these defaults could be trying to pull in too much data and hence failing. To check, log in to your Bugzilla instance and use the advanced search options to find a small number of bugs, to help you change the default values to exclude all but those, and see if they’ll be pulled in.
  3. You may need to install one or more optional Perl modules, i.e. SOAP-Lite and possibly Test-Taint. To determine if you have them installed (or to get the commands necessary to install them), go to the directory where you installed Bugzilla on your server and run the script. It will tell you what modules are installed, and what optional modules can be installed (and what they will enable). Check to see if these modules are there and if not, install them.Once that’s done, you can test it using the following. To run this you’ll need access to a machine that has the CURL command. Create a file called version.xml with the following text:<?xml version=”1.0″ encoding=”UTF-8″?>

    Then run this curl command:

    curl -X POST -H"Content-Type: text/xml" -d @version.xml <url of your Bugzilla server>/xmlrpc.cgi

    To see a successful version request, run the command against the Bugzilla “Landfill” test server. For example:

    curl -X POST -H"Content-Type: text/xml" -d @version.xml

    If all is well, the response should look like this:

    <?xml version="1.0" encoding="UTF-8"?><methodresponse><params><param /><value><struct><member><name>version</name><value><string>4.0.2</string></value></member></struct></value></param></params></methodresponse>

    If the response printed by the curl command accessing your Bugzilla server is like this, then the Tracker integration should be able to access your Bugzilla server. If this is not the kind of response you get, then your server is still not setup correctly. In general the response’s content should help you troubleshoot. For example, if contains, “The XML-RPC Interface feature is not available in this Bugzilla.” it means you need to enable the XMLRPC interface on your Bugzilla server.

    However, if you are using version 4.0.5, a bad response (such as “Application failed during request deserialization: 32612: When using XML-RPC, you cannot send data as text/xml; charset=utf-8. Only text/xml and application/xml are allowed.”) could be the result of the following Bugzilla bug:
    It’s been fixed in the patch referenced in the bug, but by the time you read this, there may be more recent updates.

  4. Another problem can be with the data that is being transferred to Tracker, if there are one or more bugs which contain multibyte characters in the description or comments. This is usually a result of pasting text into a bug from rich text email or office documents. These characters cause the length of the data stream that the web server sends to us to be incorrect, and we are unable to parse the XML on our side. In that case, determining if your bugs have any multi-byte characters and removing them, should resolve the problem. We can provide steps to help you with this if you need them.

The above should cover the most common problems. Hope it helps.

Finally, we get asked if you can integrate Tracker with Bugzilla if it’s behind your firewall. Yes, we have API servers that you can allow through your firewalls for Pivotal Tracker integration with your Bugzilla server. Please refer to our Integrations help page for more information:

If you have any questions, or there’s something this doesn’t cover, please send email to:


  1. Your version.xml is missing a close tag for the methodName element. Change the line:




  2. ugh… try:




  3. Joanne Webb says:

    Now you know the pit I dropped into! Done, and thanks very much for catching that.

  4. Velayutham says:

    Please let me know the fix or work around for the PivotalTracker integration with Bugzilla 4.2.0 issue,
    we are planning to integrate PivotalTracker and Bugzilla 4.2.0.

    Thanks in advance.

  5. Velayutham says:

    Thanks for the update Jo,
    we will be waiting for the 4.2 fix, please let us know once it is done.

  6. Mauro Ransolin says:

    Hello Joanne,

    Any news about Bugzilla 4.2 integration?


    Mauro Ransolin
    Wplex Software

  7. Joanne Webb says:

    Hello Mauro,

    We haven’t been able to make any progress, unfortunately. So, I’ve opened the following Bugzilla ticket:

    Hopefully they’ll be able to at least help identify the change in 4.2 that has broken the integration.

    Thanks for asking and I’ll update this when we get somewhere. Hopefully using Bugzilla 4.0 is a tolerable workaround for now.


  8. Jo, as I said in the bug you filed upstream, I think the problem is related to the Content-Type header not being correctly set to text/xml. If you want to talk about this, you could join the Bugzilla developers channel on IRC: irc://

  9. Joanne Webb says:

    Thanks Frédéric – I really appreciate your help, pointers and fast reply. I’ve updated our story on this and we’ll dig into it again ASAP.

    Thanks again…Jo

  10. Mauro Ransolin says:

    Hello Jo,

    Thank you for your really really fast reply! :)
    Unfortunately we can’t downgrade to 4.0.
    We’re only waiting this fixing to finish the implementation of our sw dev workflow process.
    Hope that with Frédéric’s help you can really dig into the problem ASAP.

    Best regards,


  11. Joanne Webb says:

    You’re welcome, Mauro!

    We’re hopeful we can get this out in a release in 2-3 weeks. Faster if we possibly can, but I think that’s realistic at the moment. I’ll update this as soon as there’s useful progress and I’m sorry for the inconvenience meanwhile…Jo

  12. Joanne Webb says:

    Quick update on 4.2:

    We are setting the content type header as “text/xml; charset=utf-8”. The issue seems to be that the way data is being passed to us has changed in 4.2.x and we can no longer handle empty Bugzilla bug descriptions. If all your Bugzilla bugs have descriptions, then you might be able to setup a successful integration with 4.2. We are working on this case and better exception handling in general, in case there are further data issues we haven’t isolated yet.

    Hope this helps…Jo

  13. Mauro Ransolin says:

    Great news Jo, thank you!

    I’m planing the integration to our next sprint, probably in July. Fortunately all of our bugs have description. :)
    I’ll inform you when we finish.



  14. Velayutham says:

    Hi Jo,

    I am trying to integrate Pivotal Tracker with Bugzilla 4.2 but I am unable to integrate it and getting the following error.
    “Unable to load bugs – Error occurred while retrieving Bugs”
    My Bugzilla Server details:
    Server: Bugzilla 4.2 Webserver: IIS6.0
    I have tried the troubleshooting steps mentioned in this link and the curl is not working with IIS6.0 so that I have installed Apache2.2 and tried the curl it is working fine and I am able to retrieve “version” using this configuration but I am getting the same error for this configuration too.

    In the Pivotal Integration configuration, I have added a component with 25 bugs and there is no empty description value in those 25 bugs.

    Please let me know how to proceed, am I missing anything in configuration?

    Thanks in advance.

    Thanks and Regards,

  15. Joanne Webb says:

    Hi Vels,

    Our logs aren’t revealing anything helpful, but a couple of things I noticed…

    In the project’s Integrations page, you have the Product as Bugzilla, of course you may have decided to create a product called Bugzilla in your Bugzilla 4.2 instance, but it just seemed a little unusual to me.

    the product choices are: FoodReplicator, MyOwnBadSelf, etc.

    Also, you’re using the defaults for “Bug ‘Status’ values to exclude”, i.e. RESOLVED, VERIFIED, CLOSED

    CLOSED is no longer used in 4.2 but apart from that, I took the liberty of removing those from your integration but still got the same error you are seeing.

    If you do have a Bugzilla Product in your Bugzilla instance, then Tracker is timing out trying to retrieve bugs for another reason. I’m assuming that you don’t have many bugs in your component, even unfiltered, so this may be a different data/Bugzilla bug content issue.

    Would it be possible for you to send a CSV export of all your bugs for the Bugzilla product and it’s Functional component to tracker at pivotallabs dot com to help us troubleshoot?

    Thanks and look forward to hearing from you…Jo

  16. Scott Sansom says:

    Would you have any tips if I’m seeing no messages whatsoever after adding an integration? There’s just nothing. No error messages, no success messages. The integration seems to be persisted across logins, there’s just no indication it’s doing anything….

  17. Joanne Webb says:

    Hi Scott – you’re right, we don’t have any messaging until you start trying to pull in Bugzilla bugs into the integration panel inside your actual project.

    Unless I’ve found the wrong project, (the middle word in it’s name is update) clicking the integration name at the bottom of the MORE menu (when you are viewing the project), brings in 56 bugs just fine.

    If it’s a different project, feel free to email tracker at pivotallabs dot com to let us know which it is so we can help.


  18. Scott Sansom says:

    Hi Joanne! Thanks so much for your help! This is perfect! Perhaps I just didn’t wait long enough. What sort of a schedule does Pivotal run on to pull in new items?

  19. Joanne Webb says:

    My pleasure, Scott!

    We don’t have a schedule, but that panel is not updated dynamically, you need to refresh it (with the circular icon in the panel header) to se changes in your Bugzilla instance.

    Hopefully that helps…Jo

  20. Scott Sansom says:

    Thanks again….

    Not sure if it’s integration related, but I can’t seem to assign a point value to a story created from a bug. It just says “Unestimated” and is unclickable. Is this by design?

  21. Joanne Webb says:

    You’re welcome! Not estimating bugs is by design and applies for all bugs, not just those created from an integration.

    This explains our thinking:

  22. Scott Sansom says:

    Thanks again for all the help.

    We’re now running into a bit of a strange issue where one of my collaborators has a much different experience when logging in. Since I know you can peek in to our account, his email starts with raj. For example, instead of seeing our company name (which I will omit for privacy reasons but begins with a), he sees Test2.

    Please feel free to e-mail me privately to discuss, if you have the time.

    Regardless, I must say I very, very much appreciate your assistance and we will undoubtedly be continuing with the paid service at the end of our trial. You folks rock.


  23. Joanne Webb says:

    Hello Scott – sorry for the delay responding. It seems Raj has his own account called Test2 as well as being invited to yours!

    Anyway as we’ve strayed off topic, I’ll drop you a line with more detail.

    Meanwhile, thanks very much for the good words!

  24. Joanne Webb says:

    We’ve already spend quite some time trying to determine the issue with 4.2 and are unfortunately no closer. May I suggest using 4.0.9 in the meantime.

    Apologies for the inconvenience and I’ll update this as soon as we get somewhere.

  25. J. King says:

    Hi Jo,
    We are running 4.2 bugzilla, and are trying to set it up as an interaction with our PT. Is this still a known bug, or has it it been resolved/worked around? There have been no further comments in the last 9 months.

    Is the only workaround to go back to 4.0.9? Will an upgrade to 4.2.5 resolve it?

    Thank you,

    • Joanne Webb says:

      Hi J. – unfortunately we have not been able to prioritize addressing issues with versions above 4.0.x and given the changes between 4.2 and previous versions, I don’t think any subsequent revisions will help. It’s not a quick or trivial fix and I don’t have a timeframe for it. Sorry about that. Some customers have been able to use 4.2.x but the advice remains – if it fails, downgrading is the only option for now. I’ll be sure to update this as soon as we make any progress… Jo

Post a Comment

Your Information (Name required. Email address will not be displayed with comment.)

* Copy This Password *

* Type Or Paste Password Here *

Share This